EasyUI Forum
June 23, 2018, 12:55:59 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News:
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: need ComboTreeGrid widget  (Read 105 times)
softboy99
Newbie
*
Posts: 42


View Profile Email
« on: June 07, 2018, 07:09:16 PM »

need ComboTreeGrid widget
Logged
jarry
Administrator
Hero Member
*****
Posts: 1384


View Profile Email
« Reply #1 on: June 09, 2018, 08:18:58 AM »

Please update ng-easyui to newest version.
Code:
npm update ng-easyui
The ComboTreeGridComponent looks like this:
Code:
<eui-combotreegrid
        placeholder="Select a row"
        valueField="id"
        textField="name"
        [(ngModel)]="value"
        [data]="data"
        [panelStyle]="{width:'500px'}">
    <eui-treegrid>
        <eui-grid-column field="name" title="Name"></eui-grid-column>
        <eui-grid-column field="size" title="Size"></eui-grid-column>
        <eui-grid-column field="date" title="Date"></eui-grid-column>
    </eui-treegrid>
</eui-combotreegrid>
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.18 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!